WordPress 4.7.3 Security and Maintenance Release

Following the Release Candidate, WordPress 4.7.3 is now available to all WordPress users. WordPress 4.7.3 comes as a security release for all the previous versions of WordPress. It is, thus, mandatory that you update your WordPress websites right away.

James Nylen from the WordPress Development Team posted the following six vulnerabilities that affected WordPress versions 4.7.2 and earlier:

  1. Cross-site scripting (XSS) via media file metadata.  Reported by Chris Andrè Dale, Yorick Koster, and Simon P. Briggs.
  2. Control characters can trick redirect URL validation.  Reported by Daniel Chatfield.
  3. Unintended files can be deleted by administrators using the plugin deletion functionality.  Reported by xuliang.
  4. Cross-site scripting (XSS) via video URL in YouTube embeds.  Reported by Marc Montpas.
  5. Cross-site scripting (XSS) via taxonomy term names.  Reported by Delta.
  6. Cross-site request forgery (CSRF) in Press This leading to excessive use of server resources.  Reported by Sipke Mellema.

The development team thanks the reporters for practicing responsible disclosure.

Additionally, WordPress 4.7.3 has 39 maintenance fixes to the 4.7 release series. For more information, you can check out the release notes or consult the list of changes.

Make sure you update immediately if your website doesn’t have automatic updates enabled. Download WordPress 4.7.3 or venture over to Dashboard → Updates and simply click “Update Now.”

Websites with automatic background updates are already beginning to update to WordPress 4.7.3.

Update right away to stay safe from the vulnerabilities.

Leave a Reply

Your email address will not be published. Required fields are marked *